1. Welcome to the eXophase.com forums!

    It looks like you're enjoying our site but haven't created an account yet. Why not take a minute to register for your own free account now?

    By joining, you will have access to post topics, browse threads ad-free, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Psgroove ported to Sansa e260v1

Discussion in 'PS3 Homebrew' started by yngmike, Sep 26, 2010.

  1. yngmike

    yngmike New Member

    Hey all,

    Last night I ported psgroove over to the Sandisk Sansa e260 (firmware version1).
    This should also work with Sansa e200v1 (the e200r (Rhapsody) does not work).

    Here is a quick and *rough* guide. But I'm sure you can figure it out.

    Install Rockbox 3.6 from the installer (this version was compiled for V1 (check your Sansa FIRST or it will semi brick it) Firmware V1 starts with 1.xxxxxx under settings/ about or something like that

    Download Rockbox and do a default install (installing the boot loader and software)
    http://www.rockbox.org

    After you have your Sansa working correctly with Rockbox unzip the following file to the root of your Sansa (in USB mode "MST").

    http://www.megaupload.com/?d=99YL3NOD

    Then follow the standard PSGROOVE boot procedure to get the ps3 to boot and allow you to install packages. I am pretty sure this version will not allow you to run game backups (I have not tried, nor intend to, but ultimately what you do is up to you and I will leave it at that (its a free country where I live, so what can I say?)).

    This software is provided under the GNU general license agreement
    http://www.gnu.org/licenses/gpl-2.0.html

    Sources can be found

    Here: Rockbox http://www.rockbox.org
    and Here: Rockbox patch http://github.com/shuffle2/rockbox_psgroove

    -yngmike

    ####### EDIT ########

    Proof this works

    http://www.youtube.com/watch?v=bkn4Bi8f7Mw
  2. Spiros

    Spiros Maiki

    I was just reading about this last night on psx-scene, are you id10terror on that site? Or did two guys do the same port, the same night?

    Anyway good job, this is great as I was about to order a teensy dev board and wait months, but I have a sansa e200v1(which i got brandnew off ebay just before the summer for next to nothing[bought it for a project I was planning]), lucky me. thanks.
  3. yngmike

    yngmike New Member

    Thanks spiros, this was tested with an e260 V1, but was compiled against the e200 source firmware so it should work fine. Let me know how it goes for you.

    I am currently looking at compiling this exploit against a few other rockbox compatible devices. However I can't test them, though after flashing them it could only cause a semi brick, since the initial firmware is still accessible via a hotkey on bootup (this port only modifies the software installation, not the bootloader so a full brick is not possible, unless a person fubars the the unmodded install of rockbox).

    Also by the way I am not id10terror or pirate who are claiming to have done this port. No I will say that it could be possible that we both came up with the same idea at the same time but I highly doubt it.

    I posted this on acidmods.com formums on 9-25-10 at roughly 10:30 EST...
  4. stircrazie

    stircrazie New Member

    can someone post if the sansa e200v1 psgroove is working on a sansa e280v2? i tried everything and nothing seems to be working. would i need a different compile version? all my rockbox is doing is flashing usb symbol off and on. i have rockbox 3.6 installed. tried a of different rockbox so called working psgrooves. but not working for me. thanks for you time.
  5. Spiros

    Spiros Maiki

    Some guy named Armen1er, on the PSX-Scene forum tested it on a e200v2 and says it works.

    Personally, I haven't been able to get this working on my e200v1, PS3 won't start when I have it plugged in, and the power button doesn't work so I have to switch it off at the back. To be honest, I haven't really spent enough time trying to get it to work.

    Edit - I just tried again, I reinstalled rockbox 3.6 and then copied over the psgroove patch, it doesn't work. Also, I noticed that even without it plugged into the console, when I press the ON button, immediately followed by the EJECT button, it seems as though the PS3 freezes, there's no image on the PS3 and the only button that seems to do anything is the EJECT button which makes a sound, otherwise the PS3 is frozen.

    Any ideas? Anyone?

    Edit 2 - Could it have anything to do with me being on 3.15?

    Edit 3 - Googled. Apperantly PSGroove(and all other ports of the original) doesn't work on anything lower than 3.41. I remember reading that it doesn't work on pre-3.41. but for some reason just disregarded it and assumed it would work on all previous firmwares.

    So, I guess all there is to do is update, I was only staying on 3.15 incase this brought something even greater that still required geohots exploit. But now that I think of it, the PS3 is pretty much completely open now.
  6. stircrazie

    stircrazie New Member

  7. Spiros

    Spiros Maiki

    Someone has ported PSGroove to the Sansa e200v2, I'll pm you a link to the forum where someone's tested it successfully on the v2.
  8. stircrazie

    stircrazie New Member

    sorry but i didn't find anything in that link, all i see is for version sansa e200v1. i hope your right because everything that i have don't with the psgoove.
  9. Spiros

    Spiros Maiki

    Oh! You must not have known, the sansa e200v2 is also known as the e200R (R for Rhapsody). So where it says:
    It's talking about the e200v2.

    Apperantly, you just use the files for the e200v1.
  10. yngmike

    yngmike New Member


    Well as far as I know PSgroove only has access to LV2 (game space) not kernel space. So lower firmwares might have more exploits.

    Did I read your post right? Is your PS3 not working at all now or just when you press power/eject. Also note a full power off from electric is required in between reboots for PSGroove to work
  11. Spiros

    Spiros Maiki

    No, no, my PS3 works just fine, it just won't start with the sansa(running psgroove) plugged into it. I figured it must be because I'm on 3.15, as I've read about others with the same symptoms as me while being on lower firmwares.

    Anyway thanks for this man.
  12. x3sphere

    x3sphere Administrator Staff Member

    Last played:
    Mercenary Kings on PS4
    Yeah, it only works on 3.41. I've heard a few people are working on porting the payload to lower firmwares such as 3.15 to retain OtherOS support but nothing has materialized yet.
  13. Spiros

    Spiros Maiki

    Yeah, I was just reading on KaKaRoTo's Blog he was going to try porting PSFreedom to 3.01/3.15.

    You think it's worth staying on 3.15 at this point?
  14. x3sphere

    x3sphere Administrator Staff Member

    Last played:
    Mercenary Kings on PS4
    There's not much point unless you use OtherOS. Also marcan is working on a custom Linux bootloader, which will work on 3.41.
  15. Spiros

    Spiros Maiki

    I don't use OtherOS, that's not why I'm on 3.15, I just thought that maybe something even better might come out using geohots exploit(like a more permanent "jailbreak", perhaps CFW), but I figure from now on the focus will be on 3.41, so I'll probably update sometime soon.
  16. dafranchize

    dafranchize New Member

    Is there a port for sansa fuze v2 been looking all over trying too get psgroove on my v2 fuze.
    I got the firmware info the ams http://daniel.haxx.se/sansa/amsfw.html just lost on how too port it too psgroove and everything.
  17. stircrazie

    stircrazie New Member

    is there gonna be a hermes v2 payload or om 1.13 coming to rockbox versions of ipod, sansa and iriver series?
  18. Spiros

    Spiros Maiki

    Someone has already ported it to the Sansa e200 and c200. Here.

    Although no ones confirmed if the fixes listed to be in Hermes V2 payload are present in this particular port, so if you try it out let us know if the fixes(Street fighter controller problems, F1 2010 controller problems?) are there.
  19. yngmike

    yngmike New Member

    Basically the Sansa Fuze and Clip (v1 and v2) use a different CPU the ASMS2535) which has not been ported. The maker of the base rockbox port says its not possible due to the CPU differences and inability to provide the nonblocking function required to emulate the correct hardware.

Share This Page

Style eXophase Default