• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

Steam stuck in compatability mode.

#1
I was using Steam last night and everything was working fine, shut down my computer then turn it on today and when I try and open steam I get an error saying it shouldn't be run in compatibility mode and to change it, yet when I got to properties, compatibility mode is set to Vista and grayed out making me unable to change or use it. I found a post online saying to delete the registry key for steam for compatibility which I did but the problem is still happening, any ideas?
 

x3sphere

Administrator
Staff member
Enforcer Team
#2
Have you tried booting into Safe Mode and changing the compatibility mode setting? I've never ran into a problem like this before, but worth a shot.
 
#3
I'll see if I can change it in there.

---------- Post added at 06:28 PM ---------- Previous post was at 06:03 PM ----------

The option to disable it is still grayed out, this is so fucking stupid.
 

FrozenIpaq

Justin B / Supp. Editor
Staff member
Enforcer Team
#4
That's extremely weird, have you tried to do a system restore to an earlier point in time (before it happened?). I've ran into similar problems where Windows Vista disabled the Aero theme and would require a system restore to fix as no other "fixes" seemed to work
 
#5
I haven't because in all honesty I don't have any experience or knowledge of how the system restore works. I know I personally never made a back up so I don't know if there is some auto restoration point it has or something or what.
 

FrozenIpaq

Justin B / Supp. Editor
Staff member
Enforcer Team
#6
I haven't because in all honesty I don't have any experience or knowledge of how the system restore works. I know I personally never made a back up so I don't know if there is some auto restoration point it has or something or what.
There should be some restore points (they are made automatically unless you told it otherwise). Just run System Restore and select a restore point from a few days ago if you have one
 
#7
I went back into safe mode just now and was able to change it. For whatever reason I had to go to "change settings for all users" and go into there to disable it and not just the regular check box. Still, completely retarded how something just gets enabled like that.
 
Top