• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

Stuck on firmware 3.71 M33 - Can not upgrade.

Status
Not open for further replies.

BrokenArrow

New Member
PROS needed, stuck on firmware 3.71 M33 - can not upgrade past it. UPDATES 08-06-09*

Hello exophase community, first of all I must apologize as this is my first post and I am already seeking help, but given my situation and exhausting all the possible ways I could... I need your guys help. I already posted this elsewhere and some of you probably are from those other forum boards so you might be seeing this for the second time but for the sake of getting a response by posting to a bigger audience I am posting it here as well. Now I am not an idiot when it comes to these things and I find this an extremely weird case, so here goes.

Problem: I can't upgrade firmware past 3.71 M33-4
**I CAN DOWNGRADE even down to 1.50 JUST NOT ANYTHING PAST 3.71 M33-4!**

PSP Specs:
Motherboard: TA-079
PSP Model: 1001 aka a FAT PSP
Battery: Sony 3.6v 1800 mAh Battery Pack
Memory Stick: Sony Memory Stick Pro Duo 4GB

I have tried (for many different firmware versions past 3.71):
putting the M33/OFW in PSP/Game/UPDATE folder and running it in XMB
Despertar del Cementerio (v3 -- 3.71 installer doesn't even seem to work?)
Hellcats Recovery Flasher (downgrades to 1.50 good but upgrades brick)
ChickHen
flashing by IPL's (by MMS's)
and probably some other ways as well but I can't remember them all right now

Flashing by IPL's (from the MMS's) I have tried:
PSP Pandora Deluxe,
Rains Ultra Lite MMS,
PSP Grader,
Catb50 Ultimate Magic Memory Stick Creator and none of those worked (except I got Catb50's to show the IPL screen except I could not for the life of me get past it -- I was trying the 3.80 option maybe would have worked with the 3.71 option) <- I have now tried this as well (3.71 option in catb50's and it doesn't work either to best my knowledge).
Xi-Bits NewbiInstaller

The FULL story:
The problem as mentioned in the thread title is I can not seem to update my firmware past 3.71 M33 (more accurately 3.71 M33-4). I get to the Update was successful press X to restart and when I press X it restarts the green light comes on but with the black screen and couple seconds later green light turns off (becomes bricked). This always ends up happening... I have tried different firmwares 3.80, 3.90, 4.01, 5.00, and OFFICIAL firmwares as well past 3.71 but it still does not work. The methods I have used have been putting the M33/OFW in the UPDATE folder and running it, tried Despertar del Cementerio, Hellcats Recovery Flasher, ChickHen, IPL's (by MMS's) and probably some other ways as well but I can't remember them all right now. The MANY times my PSP has bricked trying to upgrade my firmware I tried different IPL's from Magic Memory Stick Creators and only 1 really works on my PSP. I have tried PSP Pandora Deluxe, Rains Ultra Lite MMS, PSP Grader, Catb50 Ultimate Magic Memory Stick Creator and none of those worked (except I got Catb50's to show the IPL screen except I could not for the life of me get past it -- I was trying the 3.80 option maybe would have worked with the 3.71 option). What did work was Xi-Bits NewbiInstaller (which installs 3.71). That is what I've been using to unbrick it since nothing else is even unbricking it anyway. My battery (Sony 3.6v 1800 mAh Battery Pack) I have heard mixed reviews about being able to turn into a Pandora Battery but I've been able to successfully use it to unbrick my PSP along with my Magic Memory Stick.

So here I am community, hopefully somewhere here can help me as I am clueless as to why my PSP can not seem to handle going past 3.71 M33-4, I've googled and noone else seems to have this problem and I've spent much, much time trying different combinations and options. Seems so very odd and random...

The only thing I can add to this original thread today is I have found a post from someone with a similar problem from lan.st. No answers were posted or if his was even fixed but cory1492 and jas0nuk threw in their 2 cents which I'll show below.

Original page in thread:
http://www.lan.st/showthread.php?t=1430&page=46

Or just to quote them from the thread

Guy with similar problem
LEO said:
hi everyone. Sorry for posting here, i know is a forum for devs but im having a weird problem with a psp slim. The only firmware i can use is 3.71. Every time i update to a higher firmware it bricks. Even with pandora, the only firmware i can get working is 3.71 M33. I upgrade it to 3.80 (brick), 390 (brick), 4.01 (brick). While on 4.01 M33 i manage to toggle flash 0 and i notice all files were corrupt but i dont understand why only this happens after upgrading from 3.71 to any other firmware. I then flash anothers psp slim nand dump (of course after backing up my id storage keys and nanddump), but no luck still a brick. Can anyone give me feedback toward this issue. once again sorry for posting here.
jas0nuk said:
That isn't really on topic, but anyway, it sounds like a hardware problem that only manifests itself on 3.80+ (unlikely but possible) - to see if the RAM is ok, check the last post in this topic: http://forums.maxconsole.net/showthread.php?t=117116
cory1492 said:
Firmwares after 3.71 went nuts if flash2/3 (4 possibly on slim, as well, but I've never seen it happen) weren't formatted to the correct version/cypher - it basically corrupts memory (resulting in a crash/black screen) somehow when it tries to load the lflash/lfat drivers and one of the partitions doesn't match the version. If the mem test works out with a bunch of OKs (and I'm not entirely sure it will test slim extended memory, but I think it won't), then try using nandTool and/or flash23 format to repartition and format the partitions to the firmware you want to install (basically means making sure the right _updater prx's are in place.)

This could easily happen if you are using a badly made des.cem stick with mismatched prxs or a corrupted partition record (tool to check that from pandora here) - if the partition records are corrupted when it goes to format a partition it doesn't fail with an error sometimes (from pandora at any rate), it just acts like it worked.

Good luck, at any rate (and here's hoping you aren't caleebra with the failing DRAM.)
They mention checking the RAM and PSAR errors, lflash check but in order to run any of those (all cory1492's tools) they need to be ran in the elf menu which I can't seem to do so I can't even check that! Same with nandTool and flash23 formatting (formatting flash 2 and 3) but unless you guys have another way to try these things outside of elf menu or have another way to try and fix it (since I did get 1.50) then ya... here I am!

P.S EVERYTHING is backed up NAND/IDStorage etc and I can brick it some more so don't worry I am fine and know what I am doing for it.
 

january39

eXo Staff
Just about to go to work, so will study this thread longer later but my intial thoughts are much the same as you already have.

Reformat/repartion flash1 using Nandtool or DC8 but clearly you cannot access those, it seems.

Do you have a pandora, does dc8 boot at all?

I will post something better, later but i suspect it will be the same as what others have said.
 

BrokenArrow

New Member
Just about to go to work, so will study this thread longer later but my intial thoughts are much the same as you already have.

Reformat/repartion flash1 using Nandtool or DC8 but clearly you cannot access those, it seems.

Do you have a pandora, does dc8 boot at all?

I will post something better, later but i suspect it will be the same as what others have said.
Hey january39,

Ya I do not have access to DC8, it does not boot at all. After DC8 installs it bricks trying to boot up, the reason for that I see is DC8 installs CFW 5.00 M33. I also tried but can't seem to get DC3 (installs CFW 3.71 M33) to work either for some reason (installs, but bricks on boot) to get the ELF menu access to test the RAM, PSAR, lflash and use nandtool to format flash0/1/2. Unforunately since it would be DC3 and not DC8 it wouldn't come with "IDStorage Key Regeneration" which could also may be it BUT when I ran KeyCleaner (thank god somethings I can run in XMB) and IDStorage Manager it said all the keys were ok. Then again even cory himself said it can say ok but still be corrupt (short version of his long explanation). Oh and yes I do of course have/use a pandora battery. Thank you for your reply and help and hopefully I will get some resolution somewhere soon :).

EDIT: Ok so I must have done something wrong when installing DC3 earlier because I tried it again and it worked and then I installed the ELF menu and got it to work so now I am running the tests first.

IDStorage - All checked out ok
Memtest - All checked out ok
lflash check - All checked out ok
nandTool -
bad block: page 51744 block 1617
bad block: page 62432 block 1951
BUT it still said at the end and also doing the Integrity check that the Partition records seem OK plus 2 bad blocks is nothing

With this enlightenment at least I am narrowing it down I guess my next step is IDStorage and NAND restoring/repairing and flash repartitioning. OF COURSE I have backups like I stated before so yes it is all good, any help is still appreciated and any thoughts are welcome :p

EDIT2: Using the nandTool I repartitioned the lflash and using the DC3 I put 3.71 back on and tried to install 5.00 but it bricked yet again...

EDIT3: Using the nandTool and a clean nandDump I wrote that to the PSP (wrote everything but the IDStore) and using the DC3 I put 3.71 back on and tried to install 5.00 but it bricked YET again...

ARRG
 

Alex

Active Member
have you tried using key cleaner by cory?
also if you have access to the DC8 elf menu, which im not to sure you have or not you can make a new id storage.
by the way, im giving you +rep for your first post because you have done research before asking, and when you did ask, you gave us all the possible information you could. your post is a good example of a A* post, supplying all the available information makeds it easier to help us.
 

BrokenArrow

New Member
have you tried using key cleaner by cory?
also if you have access to the DC8 elf menu, which im not to sure you have or not you can make a new id storage.
by the way, im giving you +rep for your first post because you have done research before asking, and when you did ask, you gave us all the possible information you could. your post is a good example of a A* post, supplying all the available information makeds it easier to help us.
Hi alex_e,

I appreciate your response and help, thank you :). Unfortunately I can only get up to DC3 to work since I suspect it is because DC8 installs 5.00 anyway and DC3 installs 3.71 in which case I got its elf menu to work BUT of course the IDStorage Recovery was introduced in version 7 :(. I have also used Key Cleaner and all my IDStorage was ok. Since my last post I can now also add that I tried writing a full nand dump of a TA-082 to my TA-079 then used Key Cleaner to fix the corrupt keys as before that I tried to update and it gave me the it could not update error but after I fixed the keys I was able to run the updater only to end up with another brick. I would like to try another TA-079 dump but I don't have one (besides my backup) and I can't find one online.
 

Alex

Active Member
Restoring nands from other PSP's is dangerous, you can lose features doing that.

Have you tried downgrading to 1.50, then running kxploit, then update to 3.52m33 then to 3.80m33 then to 5.00m33

also, you colud try installing 5.03 and use chickhen R2 then use recovery flasher?
 

angelsniper45

New Member
have you tried using key cleaner by cory?
also if you have access to the DC8 elf menu, which im not to sure you have or not you can make a new id storage.
by the way, im giving you +rep for your first post because you have done research before asking, and when you did ask, you gave us all the possible information you could. your post is a good example of a A* post, supplying all the available information makeds it easier to help us.
Key cleaner is by chilly whilly buddy. Id use that one its proven itself over the lifespan of my psp
 

BrokenArrow

New Member
Restoring nands from other PSP's is dangerous, you can lose features doing that.

Have you tried downgrading to 1.50, then running kxploit, then update to 3.52m33 then to 3.80m33 then to 5.00m33

also, you colud try installing 5.03 and use chickhen R2 then use recovery flasher?
I know the danger of user others nand dumps :p but that is why I have mine to restore. There have been some success from people user other peoples nand dumps of the exact similar motherboards etc (not always garunteed mind you but it can work). I have not tried kxploit I suppose I will try that when I get back and I did try ChickHen, that did not work (ended up bricking).

EDIT: Alright so alex I tried what you said -> 1.50 -> 3.52 -> 3.80 -> 5.00. I got as far as 3.80 (meaning when I tried to install 3.80 it bricked), I downgraded to 1.50 and updated to 3.52 but it wouldn't let me update to 3.80.

I also can say I have found another TA-079 PSP (a friends of mine) and I got their nand dump, I wrote it to mine to try it and I couldn't do anything on my PSP so I restored mine (I had more functionality in a TA-082 then my own, weird).

At times like this I wish Devhook was updated ;( :p or somehow I could at least emulate a later firmware. I am running out of options and ideas I have no idea now really what to do :|

EDIT2: Interesting development perhaps? So this time I went in the XMB to the network update and downloaded the 5.51 OFW from Sony. I get to the install screen and I get the following error:

The Memory Stick could not be read. If you cancel, you may not be able to start the PSP system. Check that the Memory Stick is correctly inserted, and then press the x button (80010005)
and I can't get past that.... I press X agian btw and then error code changes to (80020321)

And this is before and after I have completely formatted the memory stick, what I don't understand is that I have updating using network update before with the exact same memory card (I think) and it has worked, as it should it is a Sony Memory Stick Pro Duo. I am going to try using another memory card I have and see if it works I'll post back in a few minutes.

EDIT3: Tried to boot up my PSP with the other memory card and it would not even start?! Very odd. Not bricked as it stayed on and I had to turn it off but could also mean something... SO I booted it up with the initial memory card then swapped it for the new one I wanted to try and well I got the same error... WTF. Could it perhaps be that ATM I am using a Pandora battery? It is just because I don't have a regular battery on me at the moment. The error regards the memory stick though so I don't know.

Hmmm?

Hello again everyone, it's been a couple days and *sigh* normal battery used and well I tried normal updating again through Sony Network Update to 5.51 in the XMB and it gave me the same error at the installing screen about my memory card. My mind is a blank when it comes to this situation and what it could possibly be or where to go from here...

EDIT: OK so I used hellcats recovery flasher and downgraded to 1.50, toke my other memory card and completely formatted it and got the OFW 5.51 Sony update from the XMB. Ran it and guess what, NO ERRORS. It went on installing and it INSTALLED. After it installed it shut down my PSP and I went to turn it on hoping it would have worked but it didn't............... BUT BUT BUT........... IT DIDN'T BRICK the green light has stayed on with a solid black screen.
 

nick123673

New Member
Hey broken arrow i happen to have the exact same problem. Except my psp wont let me update passed 4.01 m33-2. The only way i have gotten passed it was by making a magic memory stick for a higher firmware such as 5.00 m33-4. I just recently broke the magic memory stick i bought off of pandora sales .com and it came with firmware 4.01 m33-2 and it installed fine but then i tried to update to 5.00 m33-6 and what happened next.... a brick i had no idea what happened at the time so i just un bricked and went on (this was about a year or 2 ago) I have pretty much had the same firmware sense. I also cannot make a magic memory stick for 5.00 or anything the only luck i have had was with rains mms maker v1.0. So i cannot find a good magic memory stick maker to install a higher cfw, cant update my psp , and have no idea what a nand dump is . I have tried everything i can think of i have been stuck on this boring cfw for whp know how long and just have no clue on what to do. Thanks
 

Blazing angel

New Member
Buy a cheapo 1gb GENUINE memory stick, then update to 6.31 or use a UMD to update. Surely if you use a psp and ain't a pirate, you should have atleast a 5.00 OFW handy.
 

Spiros

Maiki
Buy a cheapo 1gb GENUINE memory stick, then update to 6.31 or use a UMD to update. Surely if you use a psp and ain't a pirate, you should have atleast a 5.00 OFW handy.
He's stuck on 3.71, so why would he buy a game that he can't play.
 

Adiuvo

Active Member
Given that this thread is over a year old and it's still getting bumped I think a closure is in order.
 
Status
Not open for further replies.
Top