1. Welcome to the eXophase.com forums!

    It looks like you're enjoying our site but haven't created an account yet. Why not take a minute to register for your own free account now?

    By joining, you will have access to post topics, browse threads ad-free, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

Gamercard not loading

Discussion in 'Feedback / Support' started by PurpleUrchin28, Dec 29, 2011.

  1. PurpleUrchin28

    PurpleUrchin28 New Member

    Last played:
    Minecraft: PlayStation 3 Edition on PS3
    Hey. Im trying to create my gamercard but its not loading. Ive been waiting for like 30minutes and its still loading. Am I doing something wrong or is it suppose to be so long?
    Thanks
  2. x3sphere

    x3sphere Administrator Staff Member

    Last played:
    Killzone Shadow Fall on PS4
    Entering info wrong most likely.
  3. PurpleUrchin28

    PurpleUrchin28 New Member

    Last played:
    Minecraft: PlayStation 3 Edition on PS3
    No, all my info is ok. If I use Internet Explorer it shows an image with an X and it says it cannot display. If I use google chrome it just loads forever...
  4. x3sphere

    x3sphere Administrator Staff Member

    Last played:
    Killzone Shadow Fall on PS4
    It can be one of two things:

    1) wrong info
    2) privacy settings on Steam / XBL preventing us from grabbing info

    Post your gamertag or PM me it and I can tell you what's happening and how to fix it.

Share This Page

Style eXophase Default