• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

IdStorage Manager

XsavioR

Member
LoL D_A will release 3.30 soon , calm down and be patient. We are saving you from making a horrible mistake. In a short time your going to see a post for the release of oe. Then you will be back thanking us for HELPING you.

Some one who says "i want to hop back on the sony boat because theyre giving away a few months of free service (that you need to pay for in a few months) " Obivously has absolutely no clue. Currently Sony is making a push to get people to install their FW. The simple truth is Sony does not intend your psp to do things like be a remote. Read pdf. Play movies you purchased elsewhere. Sony would have to do alot more to make installing sony fw worth while.

Part of the reason the option is not included publicly is just for this reason. Kids who think they know every thing and see a shiny feature (THAT WILL COST$ IN 6 MONTHS) Who want to install sony firmware because D_A's psp got old and FAILED, and the release of oe was delayed slightly. Part of our job is to identify these cases and properly educate people. Before they make there psp into a retail brick. Only to return an hour later to start spamming complaints about how a 3.30 downgrader isnt out.

The fact you refuse to understand our spot in this regard makes me think you are just a SONY monkey spamming the forum to try to stir up a bad reputation for the homebrew community. This will simply not work seeing as how every person who has delt with this so called judgment has gotten the information they requested.
 

coyboy

New Member
Hi guys, thanks for the information and contrary to what you guys might think, I am well aware of the applications and "games" available for PSP's with custom fw. The thing is I don't really care about using my PSP as a remote. I have a ... uh ... remote for that. The same goes for the other homebrewd apps. The reason I purchased the PSP is to play PlayStation brand games. Games that are made by companies who get paid to make games. Games like metal gear solid and god of war. I could care less about a 3-D remake of Mario Bros. or even the great looking Wandria. I don't mind PAYING for a quality game.

I also installed emulators on my PSP and it was fun for a short while but even that got boring. I want to play the latest greatest games that push the envelop in graphics and gameplay on the go. I certainly don't have a desire to play Chrono Trigger anymore because I already beat it when it came out 15 years ago.

I undestand that it is not just Dark_alex who is working on the homebrew scene and if he goes away, you guys are probably right in saying someone else will come forward and continue releasing "open edition" firmware. That is not my point.

My point is I paid for my PSP to do to what i want with it. Trust me, if I cared at all about the multimedia aspects or playing user-created games I would have gotten a different device.

My purpose for the original post was to find some technical assistance from some very savvy folks here. Sadly all I got was preaching about Sony being evil and Homebrew being the ONLY way to go. Sony made this PSP you guys all love so much so they can't be all bad. And this is definitely not coming from a Sony monkey as XsaviouR reffered to me as. I am just a gamer who likes fun games.

Sorry for the long post. Seeing as how I don't have the know-how to edit my PSP's idstorage key 0x0005, I guess I'm stuck at OE fw for now, you win.
 

Chilly Willy

Contributor
The only people we've seen who were wanting to restore to Sony firmware were worried about Sony taking the PSP back with custom firmware, as they wanted to return their PSP and get a different PSP elsewhere cheaper. Custom firmware runs PSP games just as well as the Sony firmware. That's why everyone has issues with folks claiming to wish to return to Sony firmware. You have nothing to gain and everything to lose, so you MUST have some ulterior motive you don't wish to voice here. Given that, you can't expect much help.
 

x3sphere

Administrator
Staff member
Enforcer Team
Coyboy, thing is you can't restore that key while running OE, your PSP will brick. I don't think there is any program that will run under original 3.03 to restore it either..

However, upgrading to 3.30 with that key modified is fine. Problem is if for whatever reason Sony decides to do something with that key in a later firmware you could be in trouble.
 

coyboy

New Member
Hi x3sphere thanks for the info. I have come to find out that my 0x0008 key is bad too so that is probably whats causing me the most grief, not key 5 but Chilly Willy's app doesn't see it as a bad key so no way for me fix it yet. And I do realize that restoring it to stock would brick a OE PSP but I am running official fw 2.71 and using HEN D to run homebrew so I think restoring would be OK for me, what do you think?

And Chilly WIlly, I am sorry but I have no ulterior motive. I really like my PSP and wouldn't dream of returning it. I have a bunch of games for it and I really do enjoy the system. I just realized that custom fw isn't for me. The only reason I went ahead and installed OE fw in the first place is because of all of the things I read about how great the emulation scene and such were. After trying out a CPS2 emu and noticing it doesn't support Marvel Vs Capcom, I realized I didn't need it. The other emulators are just as half-baked.

Since I don't have the tools or knowledge to restore my machine I'm just going to keep 2.71 and hope that a solution comes out for me in the near future.

Thanks for the replies.

Edit: To make this perfectly clear, the reason why I don't want custom fw is just that. I don't want it. Plain and simple. I do have something to lose but using custom fw. Piece of mind that if something goes wrong in the future or the scene dies, I wont be able to play the newest games. Believe me or not I couldn't care less. I just needed technical help and was denied such help. Thats all.
 

x3sphere

Administrator
Staff member
Enforcer Team
Yes, its ok to restore on 2.71.

BTW, Marvel Vs. Capcom does indeed work under the CPS2 emulator.. maybe you had a corrupt rom?
 

coyboy

New Member
Thanks for the info about the MvC. I forget what emu I used but I guess that's not really important.

Does anyone have a hash for key 0x0008? IdStorage KeyCleaner is telling me there is no key.
 

JustBlaze

New Member
guys i gotta ?

im getting a 1.5 psp online today, and i need to know, when i upgrade to 3.30 OE-A, can i play all the games or do i need some sort of emulator, also sry for being a retard, but wat is and emulator?:confused1:


ok i know that an emulators allow u to play games that u originally cant with the firmware tht u hv, and play psx, and other games but do i need one for my new psp?

thnks in advance
 

XsavioR

Member
this should be posted in the help section , others may benifit from it also.

PSx work with oe
psp work with oe

Things like nintendo games , require emu.


emu = a program that basically acts like the machines in the nintendo box. Allowing you to play the games from said system on the psp.

Immagine you got a french guy , and a spanish guy... who want to talk... an emulator is kinda like the translator. that translates the nintendo code (french) into psp code (spanish).
 

Cheezeball99

But I was committed after that birthday party...
What do you mean you called it? Are you poking fun at the fact that DaX quit making OE firmware, and now you're laughing about it!? Screw you, my friend- Screw you.
 

coyboy

New Member
What do you mean you called it? Are you poking fun at the fact that DaX quit making OE firmware, and now you're laughing about it!? Screw you, my friend- Screw you.
OK I deserve that. Sorry.

I wasn't laughing at that. It does suck that DA is leaving the scene but we gotta respect the guy for giving us so much and not really asking for anything in return.

I was just reading back and it seems I called God of War before it was even announced!
Oh and I also predicted Dark Alex leaving but that kinda sucks :(
 

Chilly Willy

Contributor
Oh and I also predicted Dark Alex leaving but that kinda sucks :(
Not much of a prediction if you think about... one day, ALL of us devs will no longer be working on the PSP. I used to be big on the Atari 400/800... know when the last time I wrote an Atari program was? Maybe '86 or '87.

:wink: 8)
 

shadowthor

New Member
Im just curious, how true is the following statement in restoring keys to upgrade to official fw, not that i need it.

________________________________________________________________________________________________________
I succeeded in the correction of 0x0005 key by working IDStorageManager on HEN-D.
As a result, I was able to loop (to the way of 3.50->1.50->OE->1.50->2.71->3.50) the firmware of my TA086 psp.

However, IDStorageManager v1.1 of a present version has the bug, and the 'verify/fix' mode doesn't work on HEN-D/3.03HEN.
This file is IDSM of the version that corrects the bug.
http://wsmith.hp.infoseek...rageManager111_271HEN.zip

The procedure is as follows.
1.The firmware is recovered to 1.50 from OE.
2.The firmware is upgraded to 2.71.
3.HEND is installed.
4.IDStorageManager of the correction version is made to work on HEND and 0x0005 key is returned to the initial state.
5.The firmware is upgraded to 3.50.

I am praying that this topic becomes your references.
________________________________________________________________________________________________________
 

Cheezeball99

But I was committed after that birthday party...
OK I deserve that. Sorry.
Eh, sorry for goin' all sickhouse on ya, I was just fairly shocked and ready to fight about anyone making fun of D_X leavin'- I had just read about him leaving, then I read your post.
 

Chilly Willy

Contributor
IDSM and KC don't work with 3.03 or 3.50 HEN. No idea why right now as I can't run either having neither of the two exploited UMDs. As such, use 2.71 or 2.80 HEN to run those apps with official Sony fw.
 
Top