• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

Snes9xTYL 0.4.2 ME for Slim!

Chilly Willy

Contributor
Chilly Willy's been busy this last week, programming with his new acquaintance CaptShoe, and here's the result. This is Snes9xTYL 0.4.2 with MediaEngine support... for the Slim! There were also a few bug fixes as well. Although this is targeted at Slim owners, it works just fine on the phat as well. On the slim, it goes in GAME, GAME360, or GAME371. On the phat, it goes in GAME3xx or GAME if you have the kernel mode set to 3.xx.

One major limitation on this version - you cannot change the speed. It's hardcoded for 333 MHz. This is because you cannot change the CPU speed while the MediaEngine is running or the Slim hangs. In a related issue, sleep mode has been disabled since sleep would have done nothing at all. As such, this will drain your battery rapidly. Once I figure out how to change the speed after the ME has been initialized, I can change this aspect pretty easily. For now, full speed, and pressing the power button does nothing.

EDIT: Since MediaFire is up and down all the time, I've also put the files on my google page.

EDIT: It has been noted that trying to put more than about 250 roms in a directory crashes the emu. So DON'T! Make subdirectories.

Snes9xTYL 0.4.2 ME for Slim
Snes9xTYL 0.4.2 ME for Slim - source code

Snes9xTYL 0.4.2 ME for Slim
Snes9xTYL 0.4.2 ME for Slim - source code
 

x3sphere

Administrator
Staff member
Enforcer Team
Wow, awesome release Chilly :) Trying it out right now.

edit: This has definitely fixed some of the sound issues, great work. Lufia II runs without a hitch.
 

Richlando

Member
Is there any way to change the fonts that SNESTYL uses?Some games are to hard to read, like Treasure of the Rudras.
 

Chilly Willy

Contributor
Is there any way to change the fonts that SNESTYL uses?Some games are to hard to read, like Treasure of the Rudras.
The emu has one built in font, fontNaga10.c, and you'd have to convert whatever font you wanted into C and recompile. I don't really have any plans to change the font handling in this. I'm working on a new conversion of SNES9x 1.51, and I'll probably use freetype2 for printing text, so you'll be able to simply choose a TTF from the menu for that. It'll be awhile before that conversion is done.

If you mean inside the game itself, that's hardcoded in the game. You'd have to hack the rom to change the font the game uses. That's well beyond the scope of this thread.
 

x3sphere

Administrator
Staff member
Enforcer Team
Is there any way to change the fonts that SNESTYL uses?Some games are to hard to read, like Treasure of the Rudras.
Question: have you tried going into the Hack / Debug menu and turning Fix HiRes hidden details to on?

This used to be a problem with Seiken Densetsu 3... but yoyofr fixed it by adding this option in.
 

neutrOpik

New Member
Tanks for your great work Chilly Willy!

Keep up!
 

Chilly Willy

Contributor
I don't know what the big fuss is. I didn't write the thing, just made it work with the ME on the Slim. It wasn't THAT hard. Me and CaptShoe spent less than a week on it, and much of that was fixing little fixes to things that irritated us.
 

jonn

New Member
help

i downloaded both of the files and did what i was told but it wont work. it keeps saying that the game cannot start or whatever. [80020148]. what should i do?
 

Chilly Willy

Contributor
i downloaded both of the files and did what i was told but it wont work. it keeps saying that the game cannot start or whatever. [80020148]. what should i do?
It's for 3.xx firmware. Make sure to put the directory in GAME3xx or GAME with the kernel mode set to 3xx. In case this needs saying, it's for CUSTOM firmware, not official firmware. :laugh:
 

jonn

New Member
help

where do i get the custom fw and how do i install it. also how do i check the kernel. i cant boot into the menu by pressing R either.
 

x3sphere

Administrator
Staff member
Enforcer Team
where do i get the custom fw and how do i install it. also how do i check the kernel. i cant boot into the menu by pressing R either.
Just check the firmware version in System Settings -> System Version

From there I'll try to help you but first I need to know which firmware you are running.
 

x3sphere

Administrator
Staff member
Enforcer Team
just says software 3.71, jon, and mac address
So you need to install 3.71 M33.

In order to do that, you'll need a Pandora battery and magic memory stick. Details on how to create both can be found here, however, you will need to know someone who has a homebrew-capable PSP.
 

x3sphere

Administrator
Staff member
Enforcer Team

Sardu

New Member
Wow, Thanks Chilly Willy.

This emulator is the main reason I use custom FW on the psp.

Just one noobish question: I haven't tried it yet, but is it "full screen" when connected to a TV?
 

Chilly Willy

Contributor
Wow, Thanks Chilly Willy.

This emulator is the main reason I use custom FW on the psp.

Just one noobish question: I haven't tried it yet, but is it "full screen" when connected to a TV?
No. I've done nothing for the TV on that. It's more work than I want to put into it at this time.
 

acecck

New Member
great job

:smile:
Chilly Willy's been busy this last week, programming with his new acquaintance CaptShoe, and here's the result. This is Snes9xTYL 0.4.2 with MediaEngine support... for the Slim! There were also a few bug fixes as well. Although this is targeted at Slim owners, it works just fine on the phat as well. On the slim, it goes in GAME, GAME360, or GAME371. On the phat, it goes in GAME3xx or GAME if you have the kernel mode set to 3.xx.

One major limitation on this version - you cannot change the speed. It's hardcoded for 333 MHz. This is because you cannot change the CPU speed while the MediaEngine is running or the Slim hangs. In a related issue, sleep mode has been disabled since sleep would have done nothing at all. As such, this will drain your battery rapidly. Once I figure out how to change the speed after the ME has been initialized, I can change this aspect pretty easily. For now, full speed, and pressing the power button does nothing.

EDIT: It has been noted that trying to put more than about 250 roms in a directory crashes the emu. So DON'T! Make subdirectories.

Snes9xTYL 0.4.2 ME for Slim
Snes9xTYL 0.4.2 ME for Slim - source code
 
Top