• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

Tweet Your Gaming Activity - Twitter Integration for Profiles

x3sphere

Administrator
Staff member
Enforcer Team

We've added a new option to link your Exophase profile with a Twitter account. When linked, our app will periodically send out a tweet notifying followers of your last played game across PSN, Steam and Xbox Live. Down the line we may expand on this with ability to control the frequency of updates, but for now, it's locked at every 24 hours.

Taking advantage of this feature is easy: simply head on over to the My Profile page and click Edit Account.

Continue reading...
 

Seth

MD Party Room
Nice Love it
 

x3sphere

Administrator
Staff member
Enforcer Team
For those that have a Twitter account linked, you can now control the frequency of tweets (from 24 hours to 1 week). This setting can be found under Preferences on the Edit Profile page.

 
Last edited:

x3sphere

Administrator
Staff member
Enforcer Team

Gummydrop

New Member
I see it under Social, but there's just text that says "Link your Exophase account with Twitter and your recent game activity will be displayed to your followers once every 24 hours." but there's nothing to actually click on or go to, to actually link them.

There's nothing for Facebook either, only thing I was able to do was verify my Steam account on the Social page.
 

x3sphere

Administrator
Staff member
Enforcer Team
I see it under Social, but there's just text that says "Link your Exophase account with Twitter and your recent game activity will be displayed to your followers once every 24 hours." but there's nothing to actually click on or go to, to actually link them.

There's nothing for Facebook either, only thing I was able to do was verify my Steam account on the Social page.
Strange, not sure what would be causing that to be honest. What browser? You may also want to try a force refresh (CTRL+F5)

This is how it should look:

 
Last edited:

Gummydrop

New Member
I figured it out, I'm using Chrome but it was Adblock Plus blocking it for some reason. This site is great though, So I should have turned it off anyway, heh. All good now.
 
Top