• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.
  • If your profile is showing up as Not Ranked, please review our rules page and follow the appeal process detailed there.

Can't Add Oculus Games?


New Member
I've started to add games from non-trackable platforms to my profile, and noticed that while Oculus can be selected, no games seem to exist. No matter what you type, it doesn't find any games. I think there's some sort of bug involved, or perhaps it's because Oculus was replaced with Meta?


As a test I tried to add an Oculus game, pressed "A" for it's name, and it immediately found "Asgard's Wrath" just fine. Then I noticed that is the only game it finds, whenever I enter any of the letters that make up its name. Nothing for "0" to "9" either.
I understand Exophase uses Giant Bomb's game library https://www.giantbomb.com/games/ , and I don't see Oculus as a platform there, but I do see Meta Quest, so you might be onto something.
Looking up aforementioned game, it only lists "PC" as a platform. https://www.giantbomb.com/asgards-wrath/3030-75661/


New Member
Oh, seems like you can find most Oculus games under "PC" anyway. I only tried the last game I played, Polygon Nightmare, and wasn't able to find that under either Oculus or PC but maybe that is simply a little too obscure

EDIT: Spoke a little too soon. I was able to add some games, but a lot of them don't exist in the database, I'd say more than half of them
Last edited: