• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

How To: Install Popsloader on 3.80 M33, 3.90 M33

x3sphere

Administrator
Staff member
Enforcer Team
Popsloader is a custom firmware plugin created by Dark_AleX, the main man behind the M33 firmwares. This plugin allows you to load your PSOne POPS games using any of the different firmware POPS versions from 3.00 to 3.72. Note: This guide has been written specifically for 3.80 M33-3 series firmware and above.

Although Popsloader takes time to install, it's well worth it for the increased compatibility with PS1 games. Here is a step-by-step guide for those new to Popsloader.

NONE of these steps write to flash! Everything described in this guide is SAFE!

Installation Guide

1. Connect the PSP via USB and enable the USB connection.

2. Download Popsloader. Extract the archive and copy the seplugins folder to the root of your memory stick. (X:\seplugins, if X is the drive letter of your PSP).

3. Download PSARDumper. This extracts required data from a firmware update. To install, simply extract the archive then copy the "newspsardumper" folder over to PSP/GAME on the memory stick.

4. Download the firmware update that corresponds to the version of POPS that you would like to install. Compatible firmware updates range from 3.00 to 3.72. Additionally, download links to all firmware update EBOOTs are available here.

5. Copy the downloaded firmware update, named as EBOOT.PBP, over to the root of your memory stick. (X:\EBOOT.PBP, if X is the drive letter of your PSP).

6. Navigate to the Game menu on your PSP and launch PSARDumper. Once launched, press square to begin extracting decrypted firmware files.

7. After a few minutes, the process should complete and your PSP will return to the XMB.

8. Once again, connect the PSP via USB and enable the USB connection.

9. Look for an F0 folder on the memory stick. Inside, copy the following files to the seplugins/popsloader folder, depending on the firmware update used:


3.00 - 3.03: kd/popsman.prx, kd/meaudio.prx, kd/pops.prx, vsh/module/pafmini.prx
3.10 - 3.30: kd/popsman.prx, kd/pops.prx, vsh/module/pafmini.prx
3.40 - 3.72: kd/popsman.prx, kd/pops.prx, vsh/module/pafmini.prx, vsh/module/libpspvmc.prx

Once you've copied the files, make sure to add a version prefix at the end of the filename. i.e. if you used firmware 3.40, then rename popsman.prx to popsman340.prx, pops.prx to pops340.prx, and so on.

After you've done this, the F0 folder on your memory stick can be safely deleted. Simply repeat steps 4 - 9 to install another pops version.

10. Now enable the plugin. To do this, boot your PSP into recovery mode by holding R when turning the power switch on, then enter plugins, and enable popsloader.prx. Exit recovery mode.

11. Congratulations! Popsloader is now installed and ready to use!

The first time you run a PS1 game that has no popsloader settings, the plugin will display a menu to select the version of pops you wish to use. To change the specific pops version for a game that already has popsloader settings, hold the R Trigger while selecting the game from the XMB Menu.

Guide based on Tenshigami's Popsloader guide for 3.30 and 3.40 OE.
 

frisomel

New Member
whoa..whenever I click on the popsloader link above..it goes to a different web page..please post the correct link..thanks!..
 

frisomel

New Member
and another thing..can you please elaborate step number 9?..sorry if I'm just a dumb-o..thanks..by the way..exophase totally rocks my socks..
 

x3sphere

Administrator
Staff member
Enforcer Team
The popsloader link works fine for me?

Tell me what you're confused with on with step 9... because it seems perfectly clear to me.
 

frisomel

New Member
the link doesn't work for me..when I click it..it goes to a page with many letters and numbers that I can't understand..

Ok tell me if I am correct..1st I have to copy all the files for the firmware on the popsloader folder..then I'll add the prefix of the version of the POPS I want on every bit of file I copied?..or I will copy ONLY the files that you specified for each firmware and put them in the same folder and add the prefixes on each file that corresponds to the firmware version that I wanna install..thanks..
 

x3sphere

Administrator
Staff member
Enforcer Team
the link doesn't work for me..when I click it..it goes to a page with many letters and numbers that I can't understand..

Ok tell me if I am correct..1st I have to copy all the files for the firmware on the popsloader folder..then I'll add the prefix of the version of the POPS I want on every bit of file I copied?..or I will copy ONLY the files that you specified for each firmware and put them in the same folder and add the prefixes on each file that corresponds to the firmware version that I wanna install..thanks..
Probably your web browser isn't identifying RAR files correctly. Do a right click -> save as on the link.

You only copy the files that are specified in the list above, then add the prefixes on each file.
 

anadriall

Member
Okay I am running 3.90 M33 or whatever it's called... 9 also confuses me because it goes up to what to do for 3.72... Also you say to download latest firmware update for POPs or something... Also confused as that list goes up to 3.80
 

x3sphere

Administrator
Staff member
Enforcer Team
Okay I am running 3.90 M33 or whatever it's called... 9 also confuses me because it goes up to what to do for 3.72... Also you say to download latest firmware update for POPs or something... Also confused as that list goes up to 3.80
Popsloader is only compatible with updates 3.00 - 3.72. So just don't use anything higher than that.
 

x3sphere

Administrator
Staff member
Enforcer Team
Ah. So I am screwed then unless I downgrade to 3.72?
Nope... I think you are confused on what this plugin does. Popsloader is for loading different versions of POPS, the PSOne emulator. With each firmware release, Sony usually changes some things in POPS. For instance there are some games that work on 3.40 POPS that don't work on the 3.90 POPS. So basically, Popsloader allows you to load these older versions of the emulator on 3.80 M33 and 3.90 M33.
 

anadriall

Member
OH!!!!!!! I thought it was an emulator all on it's own o_O

Okay, so if I download and install 3.72 then I'm good? (Not exactly the most computer literate person.....)
 

x3sphere

Administrator
Staff member
Enforcer Team
OH!!!!!!! I thought it was an emulator all on it's own o_O

Okay, so if I download and install 3.72 then I'm good? (Not exactly the most computer literate person.....)
Well you download the 3.72 update to extract certain files from it, not to actually install the update.
 

anadriall

Member
Yeah I get it now, I installed POPSloader (did all the steps) but now it doesn't have that Plugin Menu pop up... And when I hold R while selecting the game, the game just boots like normal....
 

x3sphere

Administrator
Staff member
Enforcer Team
Yeah I get it now, I installed POPSloader (did all the steps) but now it doesn't have that Plugin Menu pop up... And when I hold R while selecting the game, the game just boots like normal....
Go into recovery mode (hold R during bootup) and make sure that the pops plugin is enabled.
 

x3sphere

Administrator
Staff member
Enforcer Team
Hey. I've done everything described in the thread and have enabled the plugin in the recovery menu. However the game just boots like normal with no popsloader menu even when I hold R.

http://www.youtube.com/watch?v=z0JVQvhGQh4

^ Exactly what's happening to me except I have 3.90 m33. Does it not work with FF VII or something?
What brand memory stick do you have? I've heard popsloader does not work with Lexar memory sticks.
 

pillaysteven

New Member
What brand memory stick do you have? I've heard popsloader does not work with Lexar memory sticks.
Official Sony 8GB. I tried popsloader with 2 other games, MGS and FFVIII and it works perfectly. FFVII is the only problem. It's an ISO from the original disc so it should be fine. And it worked fine on 3.80 m33 and 3.71 m33-4. A bug in popsloader maybe?
 

x3sphere

Administrator
Staff member
Enforcer Team
Official Sony 8GB. I tried popsloader with 2 other games, MGS and FFVIII and it works perfectly. FFVII is the only problem. It's an ISO from the original disc so it should be fine. And it worked fine on 3.80 m33 and 3.71 m33-4. A bug in popsloader maybe?
Hum, odd... could just be a bug with that game then.
 
Top