• Steam recently changed the default privacy settings for all users. This may impact tracking. Ensure your profile has the correct settings by following the guide on our forums.

PSP Custom Firmware 3.52-M33-4 Released

x3sphere

Administrator
Staff member
Enforcer Team
Game Info Editor
I hate to overreact, but now he has to worry about some crazy person showing up at his house and doing something bad to him or even his family. He should move himself and his family out of that address ASAP.

That alone would be a reason for this site to not post his address. I would hate to have a guilty conscience if something bad did happen.

I don't agree with what PS3news does, and I'm pretty sure that the PS3news admin deserves every bit of it, but I other people that are not involved could get caught in the middle.

I know that I'm going to get a lot of flak for this post, but that's the way I think.

True, I guess I will edit it out. As much as I hate the site for what they did I wouldn't like to see something happening to his family.

But I wonder if he even cares. On the PSPX forum, M33 apparently are threatening to release more information if the site is not shut down. I'm quite sure they've seen this and so far have done nothing.
 

Alucard

New Member
Like I said, they are 100% wrong if they did the same thing to Alex. I know PSPNews deserves every bit of this especially since it seems like he doesn't even care.

With that said, I do feel like an idiot mentioning this because I wonder why I even care. I don't like to act all high and mighty over something that shouldn't concern me, but I guess when children are involved(I'm a school teacher btw), I tend overreact.

x3sphere, you've got my respect.
 

fantomas100

New Member
help me. im on firmware 3.52 , can i upgrade to 3.52m33 or anythin so i can then downgrade to 1.5? or am i talkin a whole load of bull? i was new to psp and upgraded by mistake, gay me i know. is there no way whatsoever of getting to 3.52m33? then back to 1.5? someone help me, or i will throw my psp at my wall. cant i just like delete the update? no? grrr!!! Thankyou!
 

supaquickt

New Member
Sorry If your on 3.52 Official Sony, your stuck for now.

Your options:

Either Trade it, Sell it or Modchip.

I'd try to sell it myself.

EDIT: Well your in luck buddy you can now downgrade 3.52 check the Unbrick thread for the Pandora release, you will need a spare battery and memstick. Oh and a PSP with 1.5 or OE M33 or WC firmware.
 

lynrossuk

New Member
semi brick again

same as last update, only buttons work after up date are brightness and volume, all rest not working. Will have to restore last version again. HELP!
 

x3sphere

Administrator
Staff member
Enforcer Team
Game Info Editor
same as last update, only buttons work after up date are brightness and volume, all rest not working. Will have to restore last version again. HELP!

I don't get it. How did you update in the first place if only the brightness and volume buttons were working?

If you can, try the Advanced -> Format flash1 and reset settings option in Recovery mode.
 

Roe

Well-Known Member
but how could you press x on the update and move to the update if none of your buttons worked?
 

moose187

New Member
hey i have 3.50 and i downloaded it to my psp but dont know how to get it going or if i can even use it , i need guidance !!! blease help!
 

moose187

New Member
LET ME CRRECT MY LAST SENTANCE! i downloaded 3.52 w33 or whatever it is and i have 3.50 already, is there n e way i can run this on mine?
 

Cheezeball99

But I was committed after that birthday party...
LET ME CRRECT MY LAST SENTANCE! i downloaded 3.52 w33 or whatever it is and i have 3.50 already, is there n e way i can run this on mine?

Yes, you have to downgrade to 1.5 first, using either the Lumines exploit or the Pandora battery, guides located HERE and HERE, respectively, then install 3.52M33, using the guide HERE.
 

supaquickt

New Member
They had a huge rock, paper, scissors fight and ps3news got owned and have never gotten over it.. The sore losers..
 

viper13

New Member
i cant load any hombrew games with this version it just loads the umd i have in my psp and with out a umd an error pops up. i tried 2 update 2 version 3.71m33 but it days i need fimware 3.52m33-3 or higher and i currently have 3.52m33-4 can some1 help.
 

Acerthief

Well-Known Member
your UMD mode is set no "normal", that's why you you'll need a UMD in order to play.

homebrew -> ms0:/PSP/GAME150
or ms0:/PSP/GAME and set the kernel to 1.5

you're good to go to upgrade to 3.71M33.
3.52M33-4 IS higher than 3.52M33-3.
 

frozen-flame

New Member
Top